Content

mxBB-Portal 2.8.x Help

The Fully Modular Portal For phpBB

Contents:

1. Introduction

2. Installing, Upgrading, Uninstalling

  • Installing

  • Upgrading

  • Uninstalling

    • 3. Administration


Content

Introduction to mxBB-Portal 2.8.x

The Fully Modular Portal For phpBB

Introduction Contents

About mxBB

Why mxBB

Why not mxBB


Confirmation

Overview

mxBB Portal is a fully modular portal and content management system (CMS) for phpBB released under the GNU General Public License version 2 (GNU GPL v2). It features dynamic pages, blocks, themes, and more, all configurable by a central, powerful, yet flexible control panel. It runs without touching phpBB by using integrated features and functions. (This true modularity has many benefits.) mxBB Portal requires phpBB to run and currently supports the mySQL and postgreSQL databases, with planned support for other database management systems (DBMSs) such as MS-SQL. mxBB Portal is the classic phpBB addon, improved and enhanced for every phpBB version released since 2001.

mxBB Portal was founded by Marc Moris, who has since left the mxBB Project Team, in 2001. mxBB Portal is developed and managed by the mxBB Project Team, which is led by Jon Ohlsson and Andrew N. The mxBB Project Team has many active contributing members from around the world, all of whom make mxBB a user-oriented, fully functional, modular open-source portal and CMS, all for an enjoyable experience. For more information regarding the mxBB Project Team, see the mxBB Project Team home.

DEMO

Download the mxBB-Portal Core (required for all setups)/ Add-on Modules (optional; download whichever ones you need)


Why mxBB?

mxBB is a very powerful content management system/portal for phpBB. What makes mxBB a superior solution worth choosing? Here's why.

Modularity

Unlike most portals and content management systems made for phpBB, mxBB is fully modular. It runs alongside phpBB without any modification, and is able to interact with phpBB data without any consequence. Due to this modular nature, it is extremely easy to customize mxBB to your liking. Since mxBB doesn't modify phpBB in any way, shape, or form, phpBB upgrades are a painless process.

Adding new features to mxBB is made easy with the modular concept. mxBB does not require phpBB MODs to add features: completely independent modules can be downloaded and installed. mxBB modules are truly "plug and play", and are able to interact with the mxBB core without modification, which allows for a seamless experience. There are many official modules made available by the mxBB Project Team, as well as third-party modules that third-party authors have shared and made available to the public.

Customizability

mxBB is extremely customizable. With the new theming system (mxBB still uses the phpBB templating system, but extends it to add new features and functions) introduced in mxBB 2.8.0, it is possible to theme nearly every element of mxBB. With the innovative portal pages concept, new pages can easily be created at your fingertips; you need not have any knowledge of HTML or PHP to do so. Content containers, called blocks, give you easy access and allows for effortless maintenance of all your site's content. Customizing things such as size, block border, orientation on the page, and much more, are all made trivial.

Support

There is a vast array of support options available to users. We have online forums and help avenues. Our team members help as frequently as they can on our forums, helping to assure that you will get some sort of answer. Our Knowledge Base has a plethora of information, answering many "why?" and "what if ...?" questions. We also offer an IRC channel for support and discussion, located at freenode.net's servers; it's located at irc://chat.freenode.net/#mxbb.

As a project team, we are devoted to our users. Do you have some feedback about mxBB that you would like to share? We will listen! We try to be as user-oriented as possible, hopefully resulting in a product that is as user-friendly as possible.


Why not mxBB?

mxBB is a fully modular portal and CMS for phpBB that requires phpBB to be installed to function. If you require a portal or CMS that doesn't require phpBB to be installed, mxBB isn't for you.

Also, mxBB is meant as a content management system, with pages that contain blocks. If you require a system that allows special posting (and you do not wish to use portal blocks to parse data from the phpBB forum side of your site), then mxBB may not be for you; you may want to look up alternative systems that specialize in your needs. For example, mxBB is not meant as a blogging tool.


Content

Installing mxBB-Portal 2.8.x

The Fully Modular Portal For phpBB

Installing Contents

Requirements

Download Packages

Uploading

The Installation Wizard

Confirmation


Requirements

These are the basic, minimum requirements to run the mxBB 2.8.0 core. The bold text indicates the optimal requirements and/or settings that are recommended.

  • PHP 4.1.0 (Latest PHP4 recommended; register_globals off)

  • phpBB 2.0.22 (Latest phpBB2 recommended)

  • mySQL3 or postgreSQL 7.1 Database (Latest mySQL4 or postgreSQL version recommended)

As you find mxBB modules that you wish to install, you will have to consult the modules' readmes to find the minimum requirements that are required to run those modules.


Download Packages

In order for mxBB-Portal to work you must download a minimum of the 'CORE' this is all the files needed for the Portal to work. In addition to this, we have a number of Modules that can be installed to provide additional functionality; Calendars, Download managers and the like.

Download the:

  • mxBB-Portal Core (required for all setups)

  • Add-on Modules (optional; download whichever ones you need)

These files are in a .zip format and may require Winzip or some other archive manager to uncompress.


Uploading
1) mxBB Portal requires a working installation of phpBB and will not run standalone. If phpBB is not installed on your system, please visit www.phpbb.com for further instructions. For the new installer, introduced in 2.7.5, you need not set the board's default theme to subSilver; you also need not set the default language to English. The installer automatically picks all of this information for you.
2) The mxBB Portal and phpBB forum must be installed in different directories. Do not mix the files up!!

Note that for ALL of the directory structure examples below, you MUST include the trailing slash at the end of the folder names! If you don't, you'll run into errors later!

Default directory structure is:

/your/path/to/public/html/YOUR_FORUM_NAME/ (this is the place where your working phpBB installation should be located)

/your/path/to/public/html/YOUR_PORTAL_NAME/ (this is the place were all mxBB files should be located)

Note that you can alternatively install mxBB in your root directory (which can be accessed via www.yourdomain.com/) while your forum can be installed in a folder within mxBB's (ie it'd be located in www.yourdomain.com/phpBB2/).

Using the default setup above, the install path variables should be:

phpBB Relative Path: ../YOUR_FORUM_NAME/
Portal URL: http://www.yourdomain.com/YOUR_PORTAL_NAME/
phpBB URL: http://www.yourdomain.com/YOUR_FORUM_ NAME/

Note #1: If you move the phpBB folder into another one before installing mxBB, the phpBB configuration (the /phpbbroot/config.php file) must also be modified to match the new phpB location. This is done in the Admin CP and the config.php file directly.

Note #2: phpBB and mxBB use separate config.php files. Do not confuse them and mix them together! They are two different files.

3) Unzip the distributed mxBB Portal files and upload

Special note
mxBB needs write access/permissions to the cache folder and the mx_meta.inc file.

## CHMOD (0777) THE FOLLOWING FILES/DIRECTORIES:
## - mxroot/cache/
## - mxroot/mx_meta.inc

For those with Windows servers, CHMOD 0777 gives read, write, and access permissions to all 3 auth types (commonly Owner, Group, and Other/Anonymous). You'll have to give the files/folders above these permissions; this depends from host to host, though usually you can do it via your hosting control panel (ex. cPanel, DirectAdmin, etc.).


The Installation Wizard

The mxBB Portal requires a working installation of phpBB and will not run standalone. If phpBB is not installed on your system, please visit http://www.phpbb.com/ for further instructions.

1) In your browser, call http://www.yourdomain.com/mxbbroot/install/mx_install.php. Replace "mxbbroot" with whatever name you had for your mxBB folder, which contains all of the mxBB files and folders.

With the installer, all of the values should already be filled in, and you should be set up to go and click "Install." However, you should go over the information filled in. If you definitely need something changed, then go ahead and see this document for details on how to set the installer to allow you to enter your own settings. Note that you should only do this if you know what you are doing.

Note that you can alternatively install mxBB in your root directory (which can be accessed via www.yourdomain.com/) while your forum can be installed in a folder within mxBB's (ie it'd be located in www.yourdomain.com/phpBB2/).

The aforementioned document describes this: "To choose your own configuration, as opposed to the installer's suggestions, open up the mx_install.php file in your favorite PHP or text editor:

Find:

Code:
 define('INSTALL_READONLY', true);

Replace With:

Code:
 // define('INSTALL_READONLY', true)

Basically, you're commenting out that line, which will in turn allow you to set up your own configuration. "

Note: The install script creates/generates the mxBB config.php file. If for some reason the install fails, you may need to remove the generated config.php manually before retrying the install. Also, if you feel like doing a fresh reinstallation, you have to remove old mxBB config.php file; otherwise, the script will try to update.

Also, some webservers deny the installer the rights to edit the config.php file. In this case you'll need to CHMOD the config.php file to 0777. (CHMOD is overviewed above). If you have any other errors regarding config.php (you shouldn't), go here.

2) Don't forget to remove the install/ and contrib/ folders after a successful installation! Otherwise, this could mean a potential security hole.

3) Installation Complete! Smile
Now enter the Portal AdminCP and configure the portal. The user interface is intuitive. For further information, visit some of our documents and Knowledge Base articles at mx-system.com.

Note 1: In version 2.8.x the syntax for the mxBB config.php file may be of interest for those who want to edit this file directly:

Code:

<?php

// mxBB-Portal auto-generated config file
// Do not change anything in this file!

// This file must be put into the mxBB-Portal directory, not into the phpBB directory.

$mx_table_prefix = "mx_";

define('MX_INSTALLED', true);

$dbms = 'mysql4';

$dbhost = 'host';
$dbname = 'DBNAME';
$dbuser = 'DBUSER';
$dbpasswd = 'DBPASSWD';

$table_prefix = 'phpbb_';

define('PHPBB_INSTALLED', true);

$phpbb_root_path = $mx_root_path . "forum/"

?>


Confirmation

Be sure that you deleted the /install/ and /contrib/ folders!


Content

Upgrading mxBB-Portal 2.8.x

The Fully Modular Portal For phpBB

Contents Upgrading

Introduction

Methods of Upgrading

Full
Changed Files
Code Changes

Confirmation


Introduction

As an administrator, it is always best for you to keep all software installations on your server as up-to-date as possible. New versions may have security and bug fixes that you need to have. Fortunately, upgrading is very easy. In order to upgrade from the mxBB 2.7 series to mxBB 2.8.0, you must be using the latest version of mxBB 2.7.

Download Packages

There are normally three different packages that you can use to upgrade your mxBB installation: Full, Changed Files, and Code Changes. However, if you are upgrading from the mxBB 2.7 series, the only option is the Full package, due to the enormity of changes between mxBB 2.7.x and mxBB 2.8.0.

All official upgrade packages can be found in this category at our main site.

In order to upgrade from the mxBB 2.7 series to mxBB 2.8.0, please download the Full package.

Before proceeding, make backups of everything: the files on your site as well as the databases available. Store these backups in a safe location.


Full Package Upgrade

To upgrade using the full package, download the full package as previously instructed. Uncompress the package file with your preferred compression utility (such as WinZIP or 7-zip), and check to see that your compression utility retained the proper directory structure (consult your compression utility's documentation for further information). Then, you must open up your preferred FTP client and connect to your site. Browse to your root directory.

Note: If you are upgrading from 2.7.x, beafore next spep, deleate all 2.7.x files except for config.php and modules that are not included in the core.

Then, upload all files and folders (except for config.php) from the full package into your webspace. All PHP files should be uploaded in ASCII mode, while all image files and template files need to be uploaded in binary mode. Consult your FTP client's documentation for further information.

Once all of the necessary files and folders have been uploaded, visit the mx_install.php file located on your site. An example of the URL you have to visit is http://www.yourdomain.com/mxbb/install/mx_install.php. This will guide you through the upgrade process, via the mxBB Installation Wizard. Follow all of the steps and fill in all of the necessary information correctly. Click "Finish" to complete the process.

Once the mxBB Installation Wizard has concluded, remove the install/ and contrib/ directories from your webspace. Visit your mxBB site and login if applicable. The upgrade process should be complete.


Changed Files Package

It is not possible to upgrade from mxBB 2.7.x to mxBB 2.8.x with the Changed Files Package, due to the enormity of the upgrade. Please upgrade using the Full package method.

To upgrade from 2.8.0 RC1 use the Full package method.


Code Changes Package

It is not possible to upgrade from mxBB 2.7.x to mxBB 2.8.x with the Code Changes package, due to the enormity of the upgrade. Please upgrade using the Full package method.

To upgrade from 2.8.0 RC1 use the Full Package method.


Content

Uninstalling mxBB-Portal 2.8.x

The Fully Modular Portal For phpBB

Unistalling Contents

Backup Data

Uninstalling


Backup Data

Use phpMyAdmin to make backups of your database. The phpBB backup feature only backs up tables with the phpBB prefix.


Uninstalling

Uninstalling mxBB is the same as uninstalling phpBB. Simply remove the files and drop all the tables with the mxBB table prefix (mx_ by default). Then manualy deleate all files and if you have the integration hack restore the original phpBB common.php file.


Introduction

With any online community, administration is a necessary task. Fortunately, with mxBB's Administration Control Panel (ACP), administration is easy. The ACP is the central vantage point for all administration-related tasks. You are able to manage both mxBB and phpBB from the mxBB ACP.

The mxBB ACP is identical to phpBB's ACP in all respects, except that it also has mxBB-related administration tasks. You should already be familiar with administration your phpBB installation before proceeding. The ACP navigation is located in the left frame of the ACP. Each category is a separate block with a centered heading.


General Admin

Introduction

The mxBB-Portal General Administration will allow you to perform general portal administration tasks. This includes at the moment general portal configuration, management and system tools.


General Configuration

1 . General->Configuration

This panel is where most of the portal settings and preferences can be changed:

  1. General Settings:

Portal Name - here the Admin can change the portal name;

Enable portal - Handy switch, when reconstructing the site. Only admin is able to view pages and browse around normally. While disabled, the message below is displayed. Portal disabled message We are currently upgrading this site with latest mxBB software.

URL to mxBB Portal - Full Portal URL, ex. http://www.example.com/http://www.example.com/

URL to your phpBB installation - Full phpBB URL, ex. http://www.example.com/phpBB/http://www.example.com/phpBB/

Use mxBB Block Cache - Block data is cached to individual cache/block_*.xml/php files. Block cache files are created/updated when blocks are edited.

Use mod_rewrite - If you're running on an Apache server and have mod_rewrite activated, you may rewrite URLS; for example, you can rewrite pages like 'page=x' with more intuitive alternatives. Please read further documentation for the mx_mod_rewrite module.

  2. Style Settings:

AdminCP Style - The default AdminCP Style.

Portal Pages Style - The default style used in portal pages, this can be overwritten from pageCP for each page.

Override user style - Replaces users style with the default (for pages).

Overall Header File (default value) - This is the default template overall_header file, e.g. overall_header.tpl.

Overall Footer File (default value) - This is the default template overall_footer file, e.g. overall_footer.tpl.

Main Layout File (default value) - This is the default template main_layout file, e.g. mx_main_layout.tpl.

Overall Navigation Block (default value) - This is the page header navigation block, provided you've chosen a overall header file which supports page navigation.

Overall Navigation Block - Chose the overall navigation block.

phpBB Statistics in Header (default value) - Links to new, unread posts in header.


mxBB Management

2 . Management

This panel is where the modules, portal pages and blocks can be managed:

To add new pages go to pageCP (Page Control Panel), it's important to chose a page template with the numbers or colons or you can add them manually later.

Then to add content to the pages you go to BlockCP before and create some new blocks or use the demo blocks that are generated with the modules .pak files or when you first install the portal.

You may need for blocks to install new modules and you have an option to do that automatically in Modules Setup section or you can add parameters and create tables manually, this for modules developers.

To use this panels, you need to have JavaScript and cookies enabled in your browser!

2.1. Modules Setup - Use this form to manage modules: installation, upgrading and module development.

2.2. Module Control Panel - Use this form to manage modules: block functions (parameters) and portal blocks.

2.3. Block Control Panel (BlockCP) - Use this form to manage portal blocks.

2.4. Page Control Panel (PageCP) - Use this form to add, delete and change the settings for Portal Pages and Page Templates.


mxBB Tools

3. System Tools

This panel is were administrators can regenerate portal cache, can check mxBB object relationships, can customize the website META tags and check phpInfo() :)


mxBB-Portal Online Help

 mxBB-Portal Help
Introduction
About mxBB-Portal
Why mxBB-Portal
Why not mxBB
Installing, Upgrading, Unistalling
Installing mxBB-Portal Help
Requirements for mxBB-Portal
Download mxBB-Portal Packages
Uploading mxBB-Portal
mxBB-Portal Installation Wizard
Confirmations
Upgrading mxBB-Portal Help
Upgrading Introduction
Methods of Upgrading
Full Package Upgrade
Changed files
Code Changes
Uninstalling
Backup Data
Uninstalling
Confirmation
mxBB-Portal Administration
Administration Introduction


mxBB-Portal Online Help

Home
Contents

Index

Search


mxBB-Portal Online Help

Type in the keyword to find:


Your browser does not support frames.


mxBB-Portal Online Help

Type in the word(s) to search for:


Index of /

Last Updated: Friday, October 26th, 2007

File name | Size | Last update | Description
[files] | <DIR> | 10/26/2007, 3:43 |
[onlinefiles] | <DIR> | 10/26/2007, 3:43 |
default.css | 7,757 | 2/11/2007, 5:47 |
formIE.css | 373 | 1/2/2005, 23:58 |
helpblankpage.html | 865 | 11/9/2004, 16:49 |
helpcontents.html | 4,000 | 2/11/2007, 5:49 |
helpheaderc.html | 3,578 | 2/11/2007, 5:16 |
helpheaderi.html | 3,652 | 2/11/2007, 5:16 |
helpheaders.html | 3,652 | 2/11/2007, 5:16 |
helpindex.html | 1,775 | 2/11/2007, 5:16 |
helpleftcon.html | 874 | 3/14/2004, 23:9 |
helpleftind.html | 837 | 3/14/2004, 23:10 |
helpleftsch.html | 838 | 7/13/2004, 4:13 |
helpsearch.html | 1,518 | 2/11/2007, 5:16 |
index2.html | 1,444 | 2/11/2007, 5:30 |
pageheader.html | 3,172 | 2/11/2007, 5:16 |
porting_mxbb-phpbb.html | 50,348 | 7/7/2007, 5:20 |
space_page.html | 296 | 3/14/2004, 23:15 |

There are 16 files and 2 directories
for a total of 215249 bytes.


mxBB-Portal Online Help

 Print Page Prev Page Next Page


Differences between phpBB, mxBB 2.7.7 and mxBB 2.8.0

Differences between phpBB, mxBB 2.7.x and mxBB 2.8.x

phpBB

mxBB 2.7.x

mxBB 2.8.0

1.

include($phpbb_root_path .'extension.inc');

include($mx_root_path .'extension.inc');

$phpEx = substr(strrchr(__FILE__, '.'), 1);

2.

$userdata = session_pagestart($user_ip, PAGE_INDEX);

init_userprefs($userdata);

$userdata = session_pagestart($user_ip, PAGE_INDEX);

mx_init_userprefs($userdata);

$mx_user->init($user_ip, PAGE_INDEX);

3.

$page_title = $lang['Title'];

$block_config = read_block_config( $block_id );
$title = $block_config[$block_id]['block_title'];

$title = $mx_block->block_info['block_title'];

4.

Configuration file

$variable = $block_config[$block_id][Parameter]['parameter_value'];

$variable = $mx_block->get_parameters( 'Parameter' );

5.

if ( !defined('IN_PHPBB') )

{

die("Hacking attempt");

}

if ( !defined('IN_PORTAL') )

{

die("Hacking attempt");

}

if( !defined('IN_PORTAL') || !is_object($mx_block))

{

die("Hacking attempt");

}

6.

include($phpbb_root_path . 'includes/page_header.'.$phpEx);

if ( !$is_block )

{

include($mx_root_path . 'includes/page_header.'.$phpEx);

}

if ( !is_object($mx_block))

{

include($mx_root_path . 'includes/page_header.'.$phpEx);

}

7.

include($phpbb_root_path . 'includes/page_footer.'.$phpEx);

if ( !$is_block )

{

include($mx_root_path . 'includes/page_footer.'.$phpEx);

}

if ( !is_object($mx_block))

{

include($mx_root_path . 'includes/page_footer.'.$phpEx);

}

8.

if ( @file_exists("./" . " viewtopic.$phpEx" )) {

if ( @file_exists( $mx_root_path . "mx_login.$phpEx" )) {

if ( @file_exists($mx_root_path . 'mx_meta.inc') ) {

9.

External block

if ( !function_exists( 'read_block_config' ) ) {

if ( !function_exists( 'read_block_config' ) ) {

10.

message_die();

message_die();

mx_message_die();

11.

redirect();

mx_redirect();

mx_redirect();

12.

smilies_pass();

smilies_pass();

mx_smilies_pass();


Index of /files

Last Updated: Friday, October 26th, 2007

File name | Size | Last update | Description
[..] | <DIR> | 10/26/2007, 3:43 | Parent directory
0.gif | 55 | 12/12/2003, 23:59 |
1.gif | 645 | 12/12/2003, 23:59 |
11.gif | 572 | 12/12/2003, 23:59 |
2.gif | 636 | 12/12/2003, 23:59 |
90.gif | 69 | 2/11/2007, 5:16 |
91.gif | 71 | 2/11/2007, 5:16 |
92.gif | 69 | 2/11/2007, 5:16 |
93.gif | 86 | 2/11/2007, 5:16 |
94.gif | 86 | 2/11/2007, 5:16 |
95.gif | 81 | 2/11/2007, 5:16 |
96.gif | 81 | 2/11/2007, 5:16 |
97.gif | 84 | 2/11/2007, 5:16 |
98.gif | 79 | 2/11/2007, 5:16 |
99.gif | 67 | 2/11/2007, 5:16 |
active_bg.gif | 169 | 12/12/2003, 23:48 |
active_left.gif | 309 | 12/12/2003, 23:48 |
active_right.gif | 293 | 12/12/2003, 23:48 |
back.gif | 397 | 12/12/2003, 23:48 |
back_on.gif | 355 | 12/12/2003, 23:48 |
backgroundbluelight.gif | 110 | 6/6/2006, 8:17 |
bg_top.gif | 223 | 12/12/2003, 23:48 |
bg_vert.gif | 35 | 12/12/2003, 23:48 |
button_left.gif | 254 | 12/12/2003, 23:48 |
button_right.gif | 95 | 12/12/2003, 23:48 |
cellpic.gif | 722 | 1/2/2005, 23:58 |
cellpic1.gif | 217 | 1/2/2005, 23:58 |
cellpic2.jpg | 1,410 | 1/2/2005, 23:58 |
cellpic3.gif | 371 | 1/2/2005, 23:58 |
chmnav.js | 1,318 | 2/11/2007, 5:16 |
helpindex.js | 1,709 | 2/11/2007, 5:16 |
helpindexdat.js | 857 | 2/11/2007, 5:16 |
home.gif | 714 | 12/12/2003, 23:48 |
home_on.gif | 758 | 12/12/2003, 23:48 |
next.gif | 393 | 12/12/2003, 23:48 |
next_on.gif | 356 | 12/12/2003, 23:48 |
pic_bg.gif | 147 | 12/12/2003, 23:48 |
print.gif | 229 | 1/23/2005, 2:39 |
print_on.gif | 267 | 1/23/2005, 2:39 |
search.js | 3,578 | 2/11/2007, 5:16 |
searchdat.js | 13,444 | 2/11/2007, 5:16 |
spacer.gif | 43 | 12/12/2003, 23:48 |
supply.js | 1,949 | 2/11/2007, 5:16 |
tree.js | 5,937 | 2/11/2007, 5:16 |
treearr.js | 2,270 | 2/11/2007, 5:16 |
Untitled.ahu | 100 | 1/6/2004, 21:16 |

There are 45 files and 1 directories
for a total of 41710 bytes.


Index of /onlinefiles

Last Updated: Friday, October 26th, 2007

File name | Size | Last update | Description
[..] | <DIR> | 10/26/2007, 3:43 | Parent directory
[administration] | <DIR> | 10/26/2007, 3:43 |
[helpfiles] | <DIR> | 10/26/2007, 3:43 |
[installing] | <DIR> | 10/26/2007, 3:43 |
[introduction] | <DIR> | 10/26/2007, 3:43 |
[uninstalling] | <DIR> | 10/26/2007, 3:43 |
[upgrading] | <DIR> | 10/26/2007, 3:43 |

There are 0 files and 7 directories
for a total of 88560 bytes.